Back to overview
Degraded
System Degradation
Oct 02 at 08:22am EDT
Affected services
Kuebix TMS
Resolved
Oct 02 at 08:44am EDT
At this time, the system is fully functional.
Affected services
Created
Oct 02 at 08:22am EDT
Some users are seeing an issue when loading a shipment to edit.
Affected services