Back to overview
Degraded
System Degradation
Oct 03 at 11:41am EDT
Affected services
Kuebix TMS
Resolved
Oct 03 at 12:03pm EDT
Full functionality restore as of 12:03PM EST
Affected services
Created
Oct 03 at 11:41am EDT
Some users are not seeing all expected rates. The engineering team is investigating.
Affected services