Back to overview
Degraded
Integrations Processing Delay
Mar 13, 2026 at 12:27pm UTC
Affected services
EDI SFTP Server
Resolved
Mar 13, 2026 at 2:00pm UTC
The delayed integrations have caught up and are now processing data as expected.
Affected services
Updated
Mar 13, 2026 at 1:30pm UTC
We have deployed a fix. Integrations are currently catching up on the backlogged data.
Affected services
Updated
Mar 13, 2026 at 1:05pm UTC
We have identified the root cause of the delay and are implementing an fix
Affected services
Created
Mar 13, 2026 at 12:27pm UTC
We are aware of a delay in processing specific integration data. The Engineering team is actively working on the issue.
Affected services