Back to overview
Degraded
Intermittent Degraded Performance
May 12, 2026 at 7:45pm UTC
Affected services
Shipment API
Order API
Account API
Carrier API
Shipment Lite API
Carrier Portal
Resolved
May 12, 2026 at 8:30pm UTC
System is functioning as intended at this time. We will continue to monitor
Affected services
Updated
May 12, 2026 at 8:15pm UTC
We are working with our vendor to resolve this.
Affected services
Created
May 12, 2026 at 7:45pm UTC
We are investigating a sporadic increase in errors when using Kuebix APIs and Portal Manager.
Affected services