Back to overview
Resolved

Degraded Performance

Jul 17, 2026 at 8:10pm UTC
Affected services
Kuebix TMS
Carrier APIs

Resolved
Jul 18, 2026 at 12:00am UTC

We will continue to monitor the Carrier APIs.

Updated
Jul 17, 2026 at 8:35pm UTC

The carrier Peninsula's API is currently performing slower than usual. Because of this, Peninsula are not being returned.

Created
Jul 17, 2026 at 8:10pm UTC

The engineering team is currently investigating an increase error rate when get rates in the Kuebix TMS